Configurare Mikrotik con RouterOS per connettività Pianeta Fibra

di Diego Scanarotti

I device dell’azienda lituana Mikrotik sono apparati a basso costo e molto versatili che, mediante l’uso del sistema operativo proprietario chiamato RouterOS, permettono di ottenere configurazioni di rete estremamente complesse.

L’uso di questi apparati è consigliato ad un utente avanzato che abbia delle solide conoscenze di networking almeno di base in quanto essi non sono dotati di sistemi di configurazione automatici che permettano al tipico utente di accendere il device e, con pochi passaggi, farlo funzionare.

Il presente tutorial parte dal presupposto che il device Mikrotik abbia attiva la configurazione di default che si presenta all’atto della prima accensione.

Lo strumento principale per effettuare le configurazioni di un qualunque device Mikrotik è l’applicativo Winbox per Windows scaricabile direttamente dal sito del costruttore.

Dopo aver fatto login al device utilizzando Winbox è possibile procedere alla configurazione mediante l’interfaccia grafica.

  • Dalla schermata principale selezionare “Interfaces” (1)
  • All’apertura della finestra selezionare la voce “VLAN” (2)
  • Cliccare sul simbolo del “+” (3):

Si aprirà la finestra mostrata di seguito.

  • Nella casella “Name” inserire la dicitura VLAN_PIANETA_FIBRA (1)
  • Nella casella “VLAN” inserire il valore 835 (2)
  • Assicurarsi che nella casella “Interface” sia selezionata la scheda ethernet alla quale è collegato il cavo proveniente dall’ONT (3)
  • Cliccare sul pulsante “OK” (4)

Ritornati alla schermata principale selezionare tra le opzioni presenti sulla sinistra la voce “IP” (1) e successivamente la voce “DHCP Client” (2):

La configurazione di default ha il client DHCP già impostato.

Per potersi adattare all’uso della VLAN di Pianeta Fibra si rende necessario fare la seguente modifica:

  • Cliccare sulla voce già presente nella schermata (1)
  • Cliccare sul simbolo indicato dal (2) e selezionare dall’elenco il nome della VLAN configurata in precedenza (VLAN_PIANETA_FIBRA)
  • Cliccare sul pulsante “OK” (3)

Di default la configurazione appena modificata è disattivata. Per attivarla:

  • Cliccare sulla voce (1). Si illumineranno i pulsanti soprastanti
  • Cliccare sulla spunta (2)

La configurazione di default deve essere ulteriormente adattata all’uso della VLAN da parte di Pianeta Fibra:

  • Dalla schermata principale selezionare la voce “Interfaces” (1)
  • Selezionare la voce “Interface List” (2)
  • Fare doppio click sulla lista chiamata “WAN” (3)
  • Selezionare dalla lista delle interfacce la VLAN creata in precedenza (VLAN_PIANETA_FIBRA) (4)
  • Cliccare sul pulsante “Apply” (5) e poi “OK

Nota importante (Deprecato):

La parte seguente può essere omessa se si tratta di attivazione PianetaFibra successiva al 15 Maggio 2021

Il sistema operativo degli apparati Mikrotik presenta una nota non conformità agli standard che impedisce il corretto uso delle reti di tipo /31 come quelle distribuite da Pianeta Fibra.

Per poter aggirare questa limitazione (sarà corretta con futuri rilasci) si rende necessario ri-specificare manualmente l’indirizzo IP e il Gateway ricevuti dal DHCP server di Pianeta Fibra.

Per poterlo fare è necessario procedere come segue:

  • Dalla schermata del DHCP Client cliccare sulla voce appena creata (1)
  • All’apertura della finestra selezionare il tab “Status” (2)
  • Segnarsi il valore dell’IP Address (nell’esempio 83.xx.xx.x5) (3)
  • Segnarsi il valore del Gateway (nell’esempio 83.xx.xx.x4) (4)
  • Cliccare sul pulsante Cancel

Dalla schermata principale:

  • Selezionare “IP” (1) e successivamente “Addresses” (2)
  • Cancellare il valore creato automaticamente dal DHCP (3)
  • Cliccare sul pulsante OK

Ritornati alla schermata principale:

  • Selezionare “IP” (1) e successivamente “Routes” (2)
  • Cancellare il valore creato automaticamente dal DHCP (3)
  • Cliccare sul pulsante OK

Aprire una finestra di terminale cliccando sul link (1) mostrato di seguito

Inserire nella finestra (2) i comandi seguenti, dopo aver sostituito i valori di esempio con quelli reali:

/ip address add address=83.xx.xx.x5 interface=VLAN_PIANETA_FIBRA network=83.xx.xx.x4

/ip route add distance=1 gateway=83.xx.xx.x4